Author Topic: DM10 not triggering after move  (Read 93 times)

DM10 not triggering after move
« on: March 12, 2021, 09:12:49 AM »
I'm finally getting around to getting my (original) DM10 back online in the new house.  I couldn't immediately locate the power supply so I ordered a 9VAC 1.3A power supply (pic attached).  The unit powers up, I can hear the metronome, but nothing seems to trigger.

Is this likely to be a power supply issue or a "plugged in the pads wrong" issue?

Thanks!




Offline Chaser

Re: DM10 not triggering after move
« Reply #1 on: March 12, 2021, 10:28:20 AM »
I'm finally getting around to getting my (original) DM10 back online in the new house.  I couldn't immediately locate the power supply so I ordered a 9VAC 1.3A power supply (pic attached).  The unit powers up, I can hear the metronome, but nothing seems to trigger.

Is this likely to be a power supply issue or a "plugged in the pads wrong" issue?

Thanks!

It's more than likely the adapter..
It should be 1.5A VAC...double check the back of the module around the power connector....I think some of the very early modules were 1.3A VAC
I use the Jameco Electronics 112336...they are reasonably priced and excellent Quality and also compatible with the Rocktron products..


Re: DM10 not triggering after move
« Reply #2 on: March 12, 2021, 06:33:37 PM »
I checked and my module says 1.3A.

Offline Chaser

Re: DM10 not triggering after move
« Reply #3 on: March 12, 2021, 07:29:32 PM »
I checked and my module says 1.3A.

Usually the module having power but not fully functional is to low amperage of the power adapter or using a DC adapter.
(Using an AC adapter into a DC device usually fries it unless it has protection...diodes etc)
There was a similar post to yours (module with 1.3A) a few years back..but the OP never reported the final result..

Dm10 power adapter problems

Do the little circles below the display show any indication when striking a  trigger ?
If no indication Have you powered down and tried just connecting just 1 trigger and see if it triggers?
Hard reset?