Author Topic: I need help with DIY ride cymbal  (Read 1046 times)

Offline DannyLee

I need help with DIY ride cymbal
« on: December 05, 2017, 07:13:43 PM »
Lol, I have a ride cymbal I made out of a pintec rubber one. I have two bell piezos and one bow piezo, I don't need anything fancy I just wanted a bell and bow sound but what it appears to be doing is only triggering one or the other.

I'm using a DM10 module.

To troubleshoot by my limited understanding, it may be that:

- I need a resistor between them and the bow must be "switch" not piezo
- I wired it wrong by just using "piezo-piezo" type construction
- I might just need to find a setting or something in the module and change it
- I should just sit in a kevorkian machine and leave this world forever

What I did notice is that if I use the "8ride1" input it triggers the bell only. If I use the "9ride2/perc1" input it triggers the bow only.
What I could do is waste an input and split the TRS cable into 2 mono inputs (I think?? LOL).

I know that if you use a 3zone ride you will have to do this but if I just want the bell and bow I shouldn't have to split it?


Do I understand all this right? I'm about to just buy an actual Alesis ride cymbal and be done with it but my goal was to fabricate everything I possible could myself.

Thanks for any feedback. This forums rocks!

Offline korakios

Re: I need help with DIY ride cymbal
« Reply #1 on: December 08, 2017, 03:15:34 PM »
Make sure that the input on the DM10 is set to piezo/piezo ;)

Offline DannyLee

Re: I need help with DIY ride cymbal
« Reply #2 on: December 08, 2017, 11:53:06 PM »
 :D  Yep, I figured it out last night. LOL.
The module was on 3zone I had to switch it to 2 zone and piezo/piezo.

Thank you though!

Offline Dobly

Re: I need help with DIY ride cymbal
« Reply #3 on: January 16, 2018, 05:22:15 AM »
Make sure that the input on the DM10 is set to piezo/piezo ;)

Where is the piezo/piezo setting you speak of?  I must be looking in the wrong place. I can't find it any place in my DM10 module or even in the manual!

Offline korakios

Re: I need help with DIY ride cymbal
« Reply #4 on: January 16, 2018, 05:32:59 AM »
Make sure that the input on the DM10 is set to piezo/piezo ;)

Where is the piezo/piezo setting you speak of?  I must be looking in the wrong place. I can't find it any place in my DM10 module or even in the manual!

p.24 on the pdf manual
InputType: Select the type of trigger you have connected to the input. Select "PIEZO" for triggers like pads or cymbals. Select "SWITCH" if you are using a drum pad with a rim switch, a cymbal with an edge switch, or a footswitch. (Note: This parameter is only seen on certain pages.)

It’s on ‘Ext Trig’ button on F1.
You can see it by selecting the second zone of the Input ,since the first always is piezo type.
 :)

Offline Dobly

Re: I need help with DIY ride cymbal
« Reply #5 on: January 16, 2018, 05:51:52 AM »
Oh, it's on the Ride BELL. Not on the Ride Bow.  No wonder i could not find it.

Thanks for your help.