Author Topic: Problem mapping e-kit with Steven Slate Drums 5.5: snare & tom trigger together!  (Read 107 times)

I'm trying to map an Alesis DM10 mkii pro e-kit with Steven Slate Drums 5.5 for a Windows 10 pc. I had it set up fine a while ago, but it recently seemed to malfunction and now I need to map the snare and tom 1 again.

I've got the e-kit connected to the computer via USB midi. I've mapped most of the kit successfully, but the problem is with the snare and rack tom 1. First of all, it seems both drums on the e-kit are triggering the same MIDI note within SSD 5.5, i.e. the both light up the C2 note when hit (see pic below where the C2 note turns blue when hit):

Now as you can see in the pic, the C2 note is assigned to rack tom 1. When I hit the snare pad on the e-kit, SSD 5.5. triggers both the snare AND rack tom 1 sound. (The rack tom 1 pad on the e-kit triggers just the rack 1 tom, which is what I want)

If I assign a snare sound from SSD 5.5 to the e-kit snare (note C2), the rack tom triggers both the snare AND rack tom sounds. The snare pad triggers the snare only (which is ok).

I assigned drum sounds to the pads by right clicking the note name (C2) in SSD 5.5 and selecting either the snare or tom 1, as in the pic below:

How do I fix this? I've had a look at the following tutorial on how to map an e-kit with SSD5.5: https://support.stevenslatedrums.com...ping-in-SSD5-5

....but I just cannot seem to solve the issue of having 2 sounds triggered by the same drum pad. It must be something to do with them both the snare and tom 1 being assigned to MIDI not C2, but i cannot seem to find a solution.

Yes you can select the MIDI learn button, but i can't figure out how this works to separate the snare and tom 1 triggers and sounds (see pic below). Is C2 supposed to be the note for the snare or the rack tom 1? What is the correct MIDI note name for each of these?

Even changing the e-kit mapping presets within SSD5.5. still results in the same issue. There isn't a map for DM10 mkii Pro either, only the DM10.
« Last Edit: November 17, 2023, 03:24:04 PM by nksoloproject »

Offline Chaser

I'm trying to map an Alesis DM10 mkii pro e-kit with Steven Slate Drums 5.5 for a Windows 10 pc. I had it set up fine a while ago, but it recently seemed to malfunction and now I need to map the snare and tom 1 again.

I've got the e-kit connected to the computer via USB midi. I've mapped most of the kit successfully, but the problem is with the snare and rack tom 1. First of all, it seems both drums on the e-kit are triggering the same MIDI note within SSD 5.5, i.e. the both light up the C2 note when hit (see pic below where the C2 note turns blue when hit):

Now as you can see in the pic, the C2 note is assigned to rack tom 1. When I hit the snare pad on the e-kit, SSD 5.5. triggers both the snare AND rack tom 1 sound. (The rack tom 1 pad on the e-kit triggers just the rack 1 tom, which is what I want)

If I assign a snare sound from SSD 5.5 to the e-kit snare (note C2), the rack tom triggers both the snare AND rack tom sounds. The snare pad triggers the snare only (which is ok).

I assigned drum sounds to the pads by right clicking the note name (C2) in SSD 5.5 and selecting either the snare or tom 1, as in the pic below:

How do I fix this? I've had a look at the following tutorial on how to map an e-kit with SSD5.5: https://support.stevenslatedrums.com...ping-in-SSD5-5

....but I just cannot seem to solve the issue of having 2 sounds triggered by the same drum pad. It must be something to do with them both the snare and tom 1 being assigned to MIDI not C2, but i cannot seem to find a solution.

Yes you can select the MIDI learn button, but i can't figure out how this works to separate the snare and tom 1 triggers and sounds (see pic below). Is C2 supposed to be the note for the snare or the rack tom 1? What is the correct MIDI note name for each of these?

Even changing the e-kit mapping presets within SSD5.5. still results in the same issue. There isn't a map for DM10 mkii Pro either, only the DM10.

See this Topic
I made some IOMaps a few years back when I didn't have the DM10 MKII Pro Module...the Hi Hat you may have to adjust..
If I get some time I'll see what the Hi Hat issue was.
I have obtained one of the DM10 MKII Pro Modules since then... I'll need to setup SSD5.5 again as I haven't used in years.

EDIT:
Also Note..the Crimson (original not Crimson II) and the DM10 MKII Pro use the same mapping..so if you run across software that does not
have the DM10 MKII Pro map..see if it has one for the original Crimson , which came out years before.
Alesis also revised the Manual from Version 1.00 to Version 1.1.
I have not checked to see what changed.
« Last Edit: November 17, 2023, 04:03:41 PM by Chaser »

Thanks for the reply, I'll try this out as soon as I get a chance. I'm sure it must be something simple that's causing the issue. Still a bit frustrating though!

I had a look at the post you linked to. So do I have to map the whole lot manually, or can I just download the .ion files you attached to that post and then import them into SSD 5.5?

I was also wondering what the 'MIDI LEARN' function in SSD does? Shouldn't it be as simple as hitting 'MIDI LEARN' then being able to map whatever pad you want to whatever MIDI note you want?  It seems like I've been chasing myself round in circles trying to fix the issue with the snare and tom sounding together!

Also, in the linked post you said the multiple Kemaps (IOMap) are a workaround as the Free version doesn't have instruments you can drag and drop..
I'm not sure what sort of drag and drop you're referring to, but I'm pretty sure the free version of SDD 5.5. has SOME drag and drop features, though maybe not the same ones you were referring to?
« Last Edit: November 17, 2023, 10:52:54 PM by nksoloproject »

Offline Chaser

I had a look at the post you linked to. So do I have to map the whole lot manually, or can I just download the .ion files you attached to that post and then import them into SSD 5.5?

I was also wondering what the 'MIDI LEARN' function in SSD does? Shouldn't it be as simple as hitting 'MIDI LEARN' then being able to map whatever pad you want to whatever MIDI note you want?  It seems like I've been chasing myself round in circles trying to fix the issue with the snare and tom sounding together!

Also, in the linked post you said the multiple Kemaps (IOMap) are a workaround as the Free version doesn't have instruments you can drag and drop..
I'm not sure what sort of drag and drop you're referring to, but I'm pretty sure the free version of SDD 5.5. has SOME drag and drop features, though maybe not the same ones you were referring to?

Just copy the .iom Files into the IOMaps Folder in the SSd5 Library Folder.
They will be under the Map List in SSD5.5

The FREE Version doesn't have Extra Instruments to drag and drop.You could drag/drop drums and mix sizes,but you couldn't drop cymbals into different locations..crashes had to be a crash..china=china,Ride=Ride etc..you are stuck with the layout..unless it's changed since 2020.
I haven't used it since.I had all the SSD4 when it was Kontakt and din't use much either.
SSD5.5 was FREE ..then it wasn't offered anymore..then it was again..SSD5 and SSD5.5 FREE are not compatible.You can't use the SSD5 expansions.
SSD5.5 was Audio Center ..then SSD5 was iLok..looking to go to iLok Cloud..so I have no idea if any changes were made etc etc. as I am not a Slate Drums fan or anything that's too Processed.Everything ends up sounding the same.SSD is a Love/Hate type of Vst..some love it..others hate it.
Usually those that hate are used to having more control over the sound and SSD5 is kinda of one dimensional..
I had enough with iLok/PACE,Dongles etc years ago with Pro-Tools and numerous Software.
I also prefer Standalone.SSD5 requires a Host.
There are numerous Sales starting since it's the Holiday Season/Black Friday...so there are a lot of options.
BFDdrums and XLN Audio has started their Promos..BFD3 expansions are Dirt cheap.

Have you watched the MIDI Learning Video?

MIDI Learn and Mapping in SSD5.5


« Last Edit: November 18, 2023, 09:17:49 AM by Chaser »

I had a look at the MIDI learning video. What I don't understand is why both the snare and tom 1 are mapped to the same MIDI note (C2). I see from the tutorial how to change the MIDI note, but what note are the snare and tom 1 supposed to be? The notes listed in your reply above (38 for the snare, 48 for tom 1)?

Offline Chaser

I had a look at the MIDI learning video. What I don't understand is why both the snare and tom 1 are mapped to the same MIDI note (C2). I see from the tutorial how to change the MIDI note, but what note are the snare and tom 1 supposed to be? The notes listed in your reply above (38 for the snare, 48 for tom 1)?

The Notes in the Keymap are the default MIDI assignments and what they are supposed to be.
You can see the same assignments in the module.The snare in 99.99% of all drum modules is always the Standard percussion Mapping.. 37..Cross/Sidestick...38-head...40 rim...the tom are usually..but depends on the manufacturer , Roland,Yamaha came out with their own as have many over the years offering more zones or software that has stacking,as the MIDI Standard originally didn't allow for multiple zones (No rims etc)..MIDI Mapping 101.

Hi, so I downloaded your io maps for the DM10 mkii Pro and tried loading them in SSD 5.5. The note numbers correspond to the table you uploaded, but I'm still getting the same problem with the snare and tom 1. I hit 'MIDI LEARN' for the snare drum note, then hit the snare pad on the e-kit. The snare pad now triggers the snare, but the tom 1 pad also now triggers the snare. I just can't seem to resolve it.

Offline Chaser

Hi, so I downloaded your io maps for the DM10 mkii Pro and tried loading them in SSD 5.5. The note numbers correspond to the table you uploaded, but I'm still getting the same problem with the snare and tom 1. I hit 'MIDI LEARN' for the snare drum note, then hit the snare pad on the e-kit. The snare pad now triggers the snare, but the tom 1 pad also now triggers the snare. I just can't seem to resolve it.

Check the Snare and Tom 1 MIDI notes assigned in the module..

EDIT:
I took the time re-install SSD5.5 FREE..connected DM10 MKII Pro...loaded all 3 of the maps.one by one..
No Issues with the snare at all..Dir,Top..Bottom,Ring.triggered properly...and no tom being triggered...nothing but the snare being triggered..No Need for MIDI Learn...
Tom 1 Triggers Tom 10  separately..no Snare being triggered or anything else...so you have something assigned incorrectly,
otherwise the only other possibility is crosstalk and the snare for the DM10 MKII Pro Kit is on a separate stand... not the rack.

« Last Edit: November 18, 2023, 01:32:26 PM by Chaser »

Hi, so I downloaded your io maps for the DM10 mkii Pro and tried loading them in SSD 5.5. The note numbers correspond to the table you uploaded, but I'm still getting the same problem with the snare and tom 1. I hit 'MIDI LEARN' for the snare drum note, then hit the snare pad on the e-kit. The snare pad now triggers the snare, but the tom 1 pad also now triggers the snare. I just can't seem to resolve it.

Check the Snare and Tom 1 MIDI notes assigned in the module..

EDIT:
I took the time re-install SSD5.5 FREE..connected DM10 MKII Pro...loaded all 3 of the maps.one by one..
No Issues with the snare at all..Dir,Top..Bottom,Ring.triggered properly...and no tom being triggered...nothing but the snare being triggered..No Need for MIDI Learn...
Tom 1 Triggers Tom 10  separately..no Snare being triggered or anything else...so you have something assigned incorrectly,

Thanks for taking the time to do that. It could be something to do with the connections from the drum pads to the module, however all sounds trigger correctly if using the internal sounds on the Alesis module, but the problems only occur with SSD5.5.

I'm not sure how this could've happened, I mean I set up a user preset in SSD5.5 about a year ago and mapped all the drums sounds and pads correctly. Everything was working fine, but then this started happening all of a sudden even if I load the preset I saved. Surely once a preset is set up and saved, it cannot alter of its own accord. Let me look go through the tutorials and your replies again and I'll see if I can somehow resolve it.

otherwise the only other possibility is crosstalk and the snare for the DM10 MKII Pro Kit is on a separate stand... not the rack.

Yes, the snare is on a separate stand. But surely that wouldn't make any difference to the drum maps and triggers?
« Last Edit: November 18, 2023, 08:28:45 PM by nksoloproject »

Edit: double post.
« Last Edit: November 18, 2023, 08:46:44 PM by nksoloproject »


Hi, so I downloaded your io maps for the DM10 mkii Pro and tried loading them in SSD 5.5. The note numbers correspond to the table you uploaded, but I'm still getting the same problem with the snare and tom 1. I hit 'MIDI LEARN' for the snare drum note, then hit the snare pad on the e-kit. The snare pad now triggers the snare, but the tom 1 pad also now triggers the snare. I just can't seem to resolve it.

Check the Snare and Tom 1 MIDI notes assigned in the module..

EDIT:
I took the time re-install SSD5.5 FREE..connected DM10 MKII Pro...loaded all 3 of the maps.one by one..
No Issues with the snare at all..Dir,Top..Bottom,Ring.triggered properly...and no tom being triggered...nothing but the snare being triggered..No Need for MIDI Learn...
Tom 1 Triggers Tom 10  separately..no Snare being triggered or anything else...so you have something assigned incorrectly,

Thanks for taking the time to do that. It could be something to do with the connections from the drum pads to the module, however all sounds trigger correctly if using the internal sounds on the Alesis module, but the problems only occur with SSD5.5.

I'm not sure how this could've happened, I mean I set up a user preset in SSD5.5 about a year ago and mapped all the drums sounds and pads correctly. Everything was working fine, but then this started happening all of a sudden even if I load the preset I saved. Surely once a preset is set up and saved, it cannot alter of its own accord. Let me look go through the tutorials and your replies again and I'll see if I can somehow resolve it.

otherwise the only other possibility is crosstalk and the snare for the DM10 MKII Pro Kit is on a separate stand... not the rack.

Yes, the snare is on a separate stand. But surely that wouldn't make any difference to the drum maps and triggers? What is crosstalk here?
[/quote]

Offline Chaser

I don't have anything else to add..out of the box the DM10 MKII Pro module and SSD5.5 FREE software both worked as they should.
You shouldn't need to use MIDI Learn at all so check SSD5.5..the maps I provided worked fine..something is screwed up somewhere.
Before doing anything I would check by using another VST or software and see if the same issue exists..if the module works fine with other Vst/software then the problem lies with SSD5.5 FREE.
If the issue remains regardless of software the last resort is to backup your trigger settings , all user kits etc to USB and do a Factory reset on the module.
I would check using another Vst/software before doing anything else.
It's been getting competitive for FREE Versions..

BFD Player is FREE NO RESTRICTIONS and includes the CORE Library for FREE..you should already have an InMusic profile..if not you should create one .install the software center and in less than 10 mins be done and up and running..

BOGREN DIGITAL is now offering a FREE Version of KRIMH Drums

ML Sound Lab offers a FREE Version of ML Drums.



EDIT:
Added Links
« Last Edit: November 18, 2023, 10:47:42 PM by Chaser »

I don't have anything else to add..out of the box the DM10 MKII Pro module and SSD5.5 FREE software both worked as they should.
You shouldn't need to use MIDI Learn at all so check SSD5.5..the maps I provided worked fine..something is screwed up somewhere.
Before doing anything I would check by using another VST or software and see if the same issue exists..if the module works fine with other Vst/software then the problem lies with SSD5.5 FREE.
If the issue remains regardless of software the last resort is to backup your trigger settings , all user kits etc to USB and do a Factory reset on the module.
I would check using another Vst/software before doing anything else.
It's been getting competitive for FREE Versions..

BFD Player is FREE NO RESTRICTIONS and includes the CORE Library for FREE..you should already have an InMusic profile..if not you should create one .install the software center and in less than 10 mins be done and up and running..

BOGREN DIGITAL is now offering a FREE Version of KRIMH Drums

ML Sound Lab offers a FREE Version of ML Drums.



EDIT:
Added Links

An update - good news, I finally got it it working with SSD 5.5. correctly! I had to go some messing around with the mapping etc, but it all seems to work ok now. I have saved the new mapping preset etc. Thanks for your help and patience!