Author Topic: strike pro firmware update 1.5 and now no sound past kit # 22  (Read 326 times)

strike pro firmware update 1.5 and now no sound past kit # 22
« on: August 03, 2022, 04:40:18 PM »
I just bought a strike pro kit in near new condition. I did the firmware update to 1.5 and now there is no sound past kit # 22. The update appears to have gone good, all the pads work according to the display, and all of the new kits are also there. I tried Alesis support and they said they have never heard of that. They sent me a link fo all of the older versions of firmware and none solved the problem. I have also done a factory default reset with no luck.

Offline Chaser

Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #1 on: August 03, 2022, 09:17:31 PM »
I just bought a strike pro kit in near new condition. I did the firmware update to 1.5 and now there is no sound past kit # 22. The update appears to have gone good, all the pads work according to the display, and all of the new kits are also there. I tried Alesis support and they said they have never heard of that. They sent me a link fo all of the older versions of firmware and none solved the problem. I have also done a factory default reset with no luck.

Welcome to the Forum !..

Do you know which Firmware/OS you had before doing the v1.5 update?
Which versions does the module currently display..UTILITY > OS.
When you re-installed the earlier updates did you use the STRIKE Editor and update DSP OS..Trigger OS and Content?
Earlier updates required the STRIKE Editor.
Did each complete successfully?..There is a reboot of the module during the procedures.

There were 22 kits added and the order of the kits moved up from v1.3 to v1.5.
The original 1st 22 Kits became 23+ over the course of the v1.3..v1.4..v1.5 updates and re-ordering.
No Kit/Instrument documentation was available for v1.3 and v1.4 Kits/Instruments.Alesis skipped documentation for those and went from v1.2 to v1.5
Normally when kits were added..they were added at the top of the order.

The Kit (.skt) files however can be renamed and they shouldn't lose the Instrument/sample location data..
Instruments(.sin) and/or samples cannot be renamed or relocated..or you will get errors.

When changing to Kits 23 and up is there a "Loading" Window?..or is there an error message.
Do any of the kits from 23 and up.. give errors when you try to change an instrument?
Error Messages will be something like "SD Card error".."Data error".."Missing".."Path not Found"..etc

Original Kit Order..thru v1.2

001-Rock'n Kit
002-Pop Rock Kit
003-Blue Jay Kit
004-NAC Kit
005-Dr. Acrylic
006-Roto Kit 1
007-Funky Bass Kit
008-Jazz Kit 1
009-3rd I Kit
010-Vintage Kit
011-Jungle Jam Kit 
012-Rose Ann Kit
013-Complextro Funk
014-Boooom 8 Kit
015-House Kit
016-Auto EDM
017-Electro Kit
018-Tonight's Air
019-Da Da Kit
020-Latin Percussion
021-Latin - Timbale
022-Orchestral 1

v1.3...added 2 Power Station Kits..Instruments/Samples.

v1.4...added 15 kits..28 instruments and over 500MB samples

v1.5...added 5 kits..71 Instruments..926 Samples.

Current Kit Order...v1.5

001-Big Bird Kit
002-Amp Room
003-Spank
004-Reggae MK2
005-Cajon
006-Birch Rock
007-Birch Rock Xst
008-Birch Gate
009-Birch Slap
010-Pop Maple
011-Pop Maple Xst
012-Natural Maple
013-NaturalMaple Xs
014-PowerStationNat
015-PowerStationPhatty
016-PowerStationBite
017-PowerStationNat2
018-Power Cell AAA
019-BeBop Jazz
020-BeBop Latin
021-BigBand Jazz
022-Vintage Sm Room

Original 1st 22 kits order moved throughout updates.

023-Rock'n Kit
024-Pop Rock Kit
025-Blue Jay Kit
026-NAC Kit
027-Djembe Kit
028-Roto Kit 1
029-Funky Bass Kit
030-Jazz Kit 1
031-3rd I Kit
032-Vintage Kit
033-Jungle Jam Kit
034-Rose Ann Kit
035-Complextro Funk
036-Boooom 8 Kit
037-House Kit
038-Auto EDM
039-Electro Kit
040-Tonight's Air
041-Da Da Kit
042-Latin Percussion
043-Latin - Timbale 
044-Orchestral 1

I don't know your OS but I attached an image of the v1.5 SD Card properties for comparison.
This will give you an indication if anything has been deleted.

EDIT:
Added v1.5 SD Card Properties for comparison....Loops Folder is ZERO (0)..No Files/Folders etc.


« Last Edit: August 04, 2022, 10:47:03 AM by Chaser »

Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #2 on: August 04, 2022, 04:37:04 PM »
Thanks for your reply!  I did not see any error messages, all of the updates seemed to work. I did use editor on 1.1, 1.2 and 1.3.  The kits load properly and they are all there in 1.5 I did try 1.4 also. I replaced the 8 gig card with a 16. and I did do the factory content update with editor, I think that was on 1.3 and the default reset too. I am using windows.

Offline Chaser

Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #3 on: August 04, 2022, 07:49:24 PM »
Thanks for your reply!  I did not see any error messages, all of the updates seemed to work. I did use editor on 1.1, 1.2 and 1.3.  The kits load properly and they are all there in 1.5 I did try 1.4 also. I replaced the 8 gig card with a 16. and I did do the factory content update with editor, I think that was on 1.3 and the default reset too. I am using windows.

I presume the SD Card you replaced is the External card.
It's odd that only the 22 kits/instruments/samples are loading/producing Sound and the original 100+ Kits are loading Instruments and not producing sound.Something like that may happen when the micro SD Card (internal) is corrupt or has failed..but there are usually error messages and affecting the entire Data Base..

The Factory Reset does not affect the internal SD Card and doing earlier updates does not erase/remove any content from the SD Card.
When I used the Factory content I used v1.3 with v1.5 content for a long time.I haven't used the Factory Content in years..
I have done a lot of modifications on these modules and replaced corrupt SD Cards, but I have never had the OS/Firmware do selective Muting on the Original Kits/Data Base.



 

Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #4 on: August 06, 2022, 12:43:19 PM »
I did not know about an internal sd card. Do you know where it is located?

Offline Chaser

Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #5 on: August 06, 2022, 04:01:04 PM »
I did not know about an internal sd card. Do you know where it is located?

Everything I have posted above including images all refer to the internal v1.5 SD Card.
The internal card contains all of the kit files(.skt)..Instrument files (.sin)..samples..nothing else...It is write protected while in the module and all edits are saved to the external SD Card.
The external SD Card folders other than a USER kit(.skt) template are empty until you save USER kits and/or start using the Editor.. adding content/samples and creating instruments and selecting USER otherwise the external card is not required to be in the module for it to operate.An empty card produces no errors.
Before you start opening up the module I recommend you check with the STRIKE Pro Owners Group on Facebook and see if anyone has had a similar problem.There are thousands of members.I don't belong to any Social media but it seems the trend these days is to open a private group rather than participating in a forum.You'll also more than likely find the instructions/procedure to replacing the SD Card as over the years there are many have added an extension/ribbon to the outside of the module and may also have links for backup files/database in case you have issues as you will be required to transfer the data back and forth,formatting etc and those files/downloads (copyright material) will never be made public by Alesis or hosted on a public forum.


Re: strike pro firmware update 1.5 and now no sound past kit # 22
« Reply #6 on: August 06, 2022, 08:06:10 PM »
Thanks again! I will try that