Author Topic: Ableton Live Intro 11 will not detect signal from Alesis Command kit  (Read 600 times)

Hi all,

I'm virtually a total beginner to recording, so please bear with me and what is *hopefully* a relatively straightforward issue! As the title suggests, I have been trying to record with my Alesis Command kit, through an audio interface, to my laptop and Ableton Live Intro 11, and while I can hear sound through earphones plugged into the audio interface, I can't see any signal coming through onto the software. I've never used any other recording software before, though I tried very briefly to do the same on Intro 10 recently before the update and still had the same problem, so I can't say it's an issue specific to 11. My equipment is as follows:

Alesis Command mesh drumkit
Ableton Live Intro 11
Windows 10 Home, version 1909, OS build 18363.1440, 64-bit, x64-based processor
MSI GS73 7RE Stealth Pro
Behringer UMC22 audio interface

I connected a 1/4" cable from the mono output of the Alesis module to the INST 2 port of the interface, then used a USB A/B cable from the interface to my laptop, which turns the 'Power' light on on the interface. I plugged in earphones into the 'phones in' port of the interface.

When I open Ableton, and go to Preferences, Audio tab, I use the MME/DirectX option (I tried downloading ASIO4ALL, but when I select ASIO from the driver options, and choose 'ASIO4all v2' it just says 'Live does not support 8000 as a sample rate for the device "ASIO4ALL v2"').

For audio input, it gives me the options of:

'Microphone (Realtek High Definition Audio) DX'
'Microphone (Realtek High Defini Wave'
'Microphone (USB Audio CODEC) DX'
'Microphone (USB Audio CODEC) Wave'

(the latter 2 only appearing when I have the interface connected to the laptop, so I assume they are the right ones to choose, though I have no idea if DX or Wave is more suitable)

For audio output, the options are similarly titled to the above 4 options, except with the word 'Speakers' in the place of the word 'Microphone'.

I have been choosing only the options with USB Audio CODEC in them for both input and output. Regardless if this is DX or Wave, still no signal comes through. In the Link Tempo MIDI tab, The MIDI Control Surface, Input and Output drop down fields all say 'None', the Input boxes are greyed out so I can't change them. The MIDI ports have Track ticked (and I read I should tick Remote as well but that didn't make any difference?) I also made my own drumkit configuration (or drum rack, I've read it being called?), and dragged it into the bottom box on the screen, but no movement changes in 'levels' etc appears on the screen when I hit any of the pads of the kit, though sound can be heard through my earphones through the interface.

Please let me know what steps I can take to get signal through to Ableton? I've tried directly plugging the USB A/B cable from the MIDI port of the Alesis module to my laptop, and was able to get signal through that way, but I kept getting noticeable latency, hence buying the interface and trying to record through that instead. Plus whenever I tried recording that way, the playback made the beats really slow for some reason!

I'd be grateful for any advice anyone could give! Apologies in advance for not understanding any music tech/recording software lingo.

« Last Edit: April 03, 2021, 01:15:55 PM by ladedadi »